+ Rispondi al Thread
Visualizzazione dei risultati da 1 a 9 su 9

Discussione: Mancata installazione programmi creati in VS2019

  1. #1
    Maverick03 non è in linea Scolaretto
    Post
    72

    Mancata installazione programmi creati in VS2019

    Chiedo aiuto per capire come mai i miei programmi creati in VS2019 e regolarmente funzionanti nello stesso, una volta compilati e pubblicati, in fase di installazione mi rimandano il messaggio:

    "Impossibile avviare l'applicazione - Per assistenza, contattare il fornitore dell'applicazione" che poi sarei io.

    Qualcuno ha avuto lo stesso problema?
    Personalmente è al prima volta che mi succede.

    Grazie per l'attenzione

    Maverick03

  2. #2
    L'avatar di AntonioG
    AntonioG non è in linea Moderatore Globale Ultimo blog: Commodore 64 e Codemotion
    Luogo
    Roma
    Post
    16,614
    Blogs
    5
    Così è veramente impossibile tentare di rispondere. Non dai nessuna indicazione che possa essere utile.
    Avvisi generali e importanti, a pena CHIUSURA thread e/o BAN
    Il crossposting è vietato.
    Le richieste di "pappa pronta" sono vietate.
    Utilizzate i tag CODE per il codice.
    Leggere il Regolamento per chiarimenti PRIMA di creare nuovi thread.
    Utilizzare sempre i PM per comunicare con i moderatori.
    Non mi contattate in PM per problemi di software, usate il forum

  3. #3
    Maverick03 non è in linea Scolaretto
    Post
    72
    Hai sicuramente ragione, provo ad inserire quello che compare nella finestra "Dettaglio"al momento della mancata installazione:

    INFORMAZIONI VERSIONE PIATTAFORMA
    Windows : 10.0.18363.0 (Win32NT)
    Common Language Runtime : 4.0.30319.42000
    System.Deployment.dll : 4.8.3752.0 built by: NET48REL1
    clr.dll : 4.8.4180.0 built by: NET48REL1LAST_B
    dfdll.dll : 4.8.3752.0 built by: NET48REL1
    dfshim.dll : 10.0.18362.1 (WinBuild.160101.0800)

    ORIGINI
    URL distribuzione : file:///C:/Users/giang/Documents/MIEI%20PROGRAMMI%20PUBBLICATI/Scorta%20NewDatabase/Scorta%20NewDatabase.application

    IDENTITÀ
    Identità distribuzione : Scorta NewDatabase.application, Version=1.0.0.0, Culture=neutral, PublicKeyToken=6e4df0890df36b3d, processorArchitecture=msil

    RIEPILOGO APPLICAZIONE
    * Applicazione installabile.

    RIEPILOGO ERRORI
    Quello che segue è un riepilogo degli errori. Informazioni dettagliate su tali errori sono disponibili più avanti nel registro.
    * L'attivazione di C:\Users\giang\Documents\MIEI PROGRAMMI PUBBLICATI\Scorta NewDatabase\Scorta NewDatabase.application ha causato un'eccezione. Sono stati rilevati i messaggi di errore seguenti:
    + Eccezione durante l'operazione di archiviazione.
    + Valore non compreso nell'intervallo previsto.

    RIEPILOGO ERRORI TRANSAZIONE ARCHIVIO COMPONENTI
    Nessun errore di transazione rilevato.

    AVVISI
    Nessun avviso durante l'operazione.

    STATO OPERAZIONE
    * [17/05/2020 10:58:28] : Attivazione di C:\Users\giang\Documents\MIEI PROGRAMMI PUBBLICATI\Scorta NewDatabase\Scorta NewDatabase.application avviata.
    * [17/05/2020 10:58:28] : Elaborazione del manifesto di distribuzione completata.

    DETTAGLI ERRORI
    Durante l'operazione sono stati rilevati gli errori seguenti.
    * [17/05/2020 10:58:28] System.Deployment.Application.DeploymentException (ComponentStore)
    - Eccezione durante l'operazione di archiviazione.
    - Origine: System.Deployment
    - Analisi dello stack:
    in System.Deployment.Application.ComponentStore.Submi tStoreTransaction(StoreTransactionContext storeTxn, SubscriptionState subState)
    in System.Deployment.Application.ComponentStore.SetPe ndingDeployment(SubscriptionState subState, DefinitionIdentity deployId, DateTime checkTime)
    in System.Deployment.Application.SubscriptionStore.Se tLastCheckTimeToNow(SubscriptionState subState)
    in System.Deployment.Application.ApplicationActivator .PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl, Uri& deploymentUri)
    in System.Deployment.Application.ApplicationActivator .PerformDeploymentActivationWithRetry(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
    --- Fine traccia dello stack da posizione precedente dove è stata generata l'eccezione ---
    in System.Runtime.ExceptionServices.ExceptionDispatch Info.Throw()
    in System.Deployment.Application.ApplicationActivator .PerformDeploymentActivationWithRetry(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
    in System.Deployment.Application.ApplicationActivator .ActivateDeploymentWorker(Object state)
    --- Eccezione interna ---
    System.ArgumentException
    - Valore non compreso nell'intervallo previsto.
    - Origine: System.Deployment
    - Analisi dello stack:
    in System.Deployment.Internal.Isolation.IStore.Transa ct(IntPtr cOperation, StoreTransactionOperation[] rgOperations, UInt32[] rgDispositions, Int32[] rgResults)
    in System.Deployment.Internal.Isolation.Store.Transac t(StoreTransactionOperation[] operations, UInt32[] rgDispositions, Int32[] rgResults)
    in System.Deployment.Application.ComponentStore.Submi tStoreTransaction(StoreTransactionContext storeTxn, SubscriptionState subState)

    DETTAGLI TRANSAZIONE ARCHIVIO COMPONENTI
    * Transazione in [17/05/2020 10:58:28]
    + System.Deployment.Internal.Isolation.StoreOperatio nSetDeploymentMetadata
    - Stato: Set
    - HRESULT: 0x0
    + System.Deployment.Internal.Isolation.StoreTransact ionOperationType (27)
    - HRESULT: 0x80070057

    Spero possa essere utile, grazie

    Maverick03

  4. #4
    Maverick03 non è in linea Scolaretto
    Post
    72
    Ho trovato la soluzione al mio problema e la posto per una conferma e nella eventualità che possa servire ad altri.
    In pratica ho cancellato la cache di Clickonce, che si trova:

    %userprofile%\AppData\Local\Apps\2.0\*.*

    dopo di che i programmi si sono installati regolarmente.

    Magari qualcuno può avere lo stesso problema.

    Un saluto a tutti

    Maverick03

  5. #5
    L'avatar di AntonioG
    AntonioG non è in linea Moderatore Globale Ultimo blog: Commodore 64 e Codemotion
    Luogo
    Roma
    Post
    16,614
    Blogs
    5
    Certo che l'hai trovata ... te l'ho data io ...

    Questa volta passi, ricorda comunque che il crossposting non è consentito e non è apprezzato.
    Avvisi generali e importanti, a pena CHIUSURA thread e/o BAN
    Il crossposting è vietato.
    Le richieste di "pappa pronta" sono vietate.
    Utilizzate i tag CODE per il codice.
    Leggere il Regolamento per chiarimenti PRIMA di creare nuovi thread.
    Utilizzare sempre i PM per comunicare con i moderatori.
    Non mi contattate in PM per problemi di software, usate il forum

  6. #6
    Maverick03 non è in linea Scolaretto
    Post
    72
    Se ho commesso qualche errore è stato in buona fede e comunque chiedo scusa fin da subito, ma non capisco il "... te l'ho data io ..."

    Sempre disponibile a riconoscere di aver sbagliato

    Maverick03

  7. #7
    Luogo
    Lazio
    Post
    1,655
    Blogs
    21
    Quote Originariamente inviato da Maverick03 Visualizza il messaggio
    ...
    ma non capisco il "... te l'ho data io ..."
    ...
    in molti frequentano più di un forum;
    è comunque apprezzato il gesto di aver riportato la soluzione anche qui
    Ciao sspintux
    ------------------------------------------------------------

    O Santo Protettore dell'informatico quadratico medio, se puoi allontana da me questo cetriolo amaro!
    Azz! ... questo è un grande porck-around; potremmo addirittura farlo passare per una funzionalità avanzata

  8. #8
    Maverick03 non è in linea Scolaretto
    Post
    72
    Allora ho capito, grazie comunque, non ripeterò l'errore

  9. #9
    L'avatar di AntonioG
    AntonioG non è in linea Moderatore Globale Ultimo blog: Commodore 64 e Codemotion
    Luogo
    Roma
    Post
    16,614
    Blogs
    5
    Quote Originariamente inviato da Maverick03 Visualizza il messaggio
    non capisco il "... te l'ho data io ..."
    Mi sembrava chiaro chi fosse "oregon".

    Comunque, ti ho già detto che non c'è nessun problema.
    Avvisi generali e importanti, a pena CHIUSURA thread e/o BAN
    Il crossposting è vietato.
    Le richieste di "pappa pronta" sono vietate.
    Utilizzate i tag CODE per il codice.
    Leggere il Regolamento per chiarimenti PRIMA di creare nuovi thread.
    Utilizzare sempre i PM per comunicare con i moderatori.
    Non mi contattate in PM per problemi di software, usate il forum

+ Rispondi al Thread

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi