+ Rispondi al Thread
Visualizzazione dei risultati da 1 a 7 su 7

Discussione: Query non funzionante su vb6 ma funzionante su phpmyadmin

  1. #1
    L'avatar di qweasdzxc
    qweasdzxc non è in linea Scolaretto
    Post
    207

    Query non funzionante su vb6 ma funzionante su phpmyadmin

    Salve come da descrizione non riesco a capire perchè la seguente query sia funzionante su phpmyadmin e non funzioni su vb6. (I dati li visualizzo su una MSHFLEXGRID)

    codice:
    Adodc1.RecordSource = "SELECT progressivo,ditta,intestatario,riferimento, CONCAT(tipologia,' - ',formato),DATE_FORMAT(DataRegistrazione, '%d/%m/%Y'),DATE_FORMAT(DataUscita, '%d/%m/%Y') ,notex,motivazione,statusbreve,status FROM commissioni WHERE  CAST(DataUscita AS char) LIKE '1806-04-19%' and status <>'OFF' AND motivazione='LAVORABILE'"

  2. #2
    Luogo
    Lazio
    Post
    1,656
    Blogs
    21
    non è che status è una parola riservata ?
    Ciao sspintux
    ------------------------------------------------------------

    O Santo Protettore dell'informatico quadratico medio, se puoi allontana da me questo cetriolo amaro!
    Azz! ... questo è un grande porck-around; potremmo addirittura farlo passare per una funzionalità avanzata

  3. #3
    L'avatar di qweasdzxc
    qweasdzxc non è in linea Scolaretto
    Post
    207
    ciao grazie per la risposta... tatus è un campo del database e in tutte le altre query di questo programma non da problemi.

  4. #4
    L'avatar di AntonioG
    AntonioG non è in linea Moderatore Globale Ultimo blog: Commodore 64 e Codemotion
    Luogo
    Roma
    Post
    16,616
    Blogs
    5
    Ma quale errore hai?
    Avvisi generali e importanti, a pena CHIUSURA thread e/o BAN
    Il crossposting è vietato.
    Le richieste di "pappa pronta" sono vietate.
    Utilizzate i tag CODE per il codice.
    Leggere il Regolamento per chiarimenti PRIMA di creare nuovi thread.
    Utilizzare sempre i PM per comunicare con i moderatori.
    Non mi contattate in PM per problemi di software, usate il forum

  5. #5
    L'avatar di gibra
    gibra non è in linea Amanuense
    Luogo
    Breganze (VI)
    Post
    6,145

  6. #6
    L'avatar di qweasdzxc
    qweasdzxc non è in linea Scolaretto
    Post
    207
    Non ho nessun errore, non visualizzo nessun dato, mentre se lancio la query da phpmyadmin mi restituisce i dati. L'istruzione "CAST(DataUscita AS char)" l'ho usata per potere effettuare il LIKE su un campo datetime. Dove sbaglio?
    Ultima modifica di qweasdzxc; 10-05-2018 15:05 

  7. #7
    Luogo
    Lazio
    Post
    1,656
    Blogs
    21
    Quote Originariamente inviato da qweasdzxc Visualizza il messaggio
    Non ho nessun errore, non visualizzo nessun dato, mentre se lancio la query da phpmyadmin mi restituisce i dati. L'istruzione "CAST(DataUscita AS char)" l'ho usata per potere effettuare il LIKE su un campo datetime. Dove sbaglio?
    E togli le condizioni nella where provandole una alla volta
    Ciao sspintux
    ------------------------------------------------------------

    O Santo Protettore dell'informatico quadratico medio, se puoi allontana da me questo cetriolo amaro!
    Azz! ... questo è un grande porck-around; potremmo addirittura farlo passare per una funzionalità avanzata

+ Rispondi al Thread

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi