+ Rispondi al Thread
Pagina 2 di 2 primaprima 12
Visualizzazione dei risultati da 11 a 18 su 18

Discussione: WS lento nella trasmissione dei dati

  1. #11
    L'avatar di bumm
    bumm non è in linea Very Important Person Ultimo blog: [VB2010] ComboBox ed Enumeratori
    Luogo
    Bologna
    Post
    2,142
    Blogs
    1
    Sono abbastanza convinto che il problema è nella comunicazione tra la tua applicazione e ws.
    Hai affermato che:
    1. se l'applicazione e WS si trovano nello stesso pc - la chiamata al metodo WS(che esegue una query e restituisce i risultati) dura 1s.
    2. se l'applicazione e WS si trovano sulle macchine diverse - stessa identica chiamata dura 10s.
    Da questo possiamo dedurra che il problema e nel trasporto.
    Come ti colleghi al WS che si trova sull'altra macchina? Usi IP oppure nome della macchina in rete? potresti postare la configurazione di endpoint?
    In qualsiasi caso sembra che il problema non è legato a MySql.
    "HeloWorld.exe" 17 errors, 31 warnings.

    Non mi mandate le richieste di aiuto via PM! Non vi risponderò! Tutte le domande fateli sul forum!

  2. #12
    marco.santilli non è in linea Scolaretto
    Post
    443
    Quote Originariamente inviato da bumm Visualizza il messaggio
    Sono abbastanza convinto che il problema è nella comunicazione tra la tua applicazione e ws.
    Hai affermato che:
    1. se l'applicazione e WS si trovano nello stesso pc - la chiamata al metodo WS(che esegue una query e restituisce i risultati) dura 1s.
    2. se l'applicazione e WS si trovano sulle macchine diverse - stessa identica chiamata dura 10s.
    Da questo possiamo dedurra che il problema e nel trasporto.
    Come ti colleghi al WS che si trova sull'altra macchina? Usi IP oppure nome della macchina in rete? potresti postare la configurazione di endpoint?
    In qualsiasi caso sembra che il problema non è legato a MySql.
    non ci sono query lente...
    quindi il problema è sui ws, sulla restituzione dei dati...
    la connessione ai ws avviene attraverso indirizzo ip e non nome macchina...

    avete nuove idee per proseguire con i test e capire il problema?
    ciao e grazie
    i7 3770K --- Asus P8z77 --- 2x4Gb Corsair Vengeance 2133MHz--- Enermax NoiseTaker II 600w --- SSD: 128Gb Vertex 4 --- WD 1000Gb --- WD 2000Gb --- ASUS ATI5850 1Gb --- Case: Kandalf 25cm Fan --- Tastiera Logitech G15 --- Mouse Razer Copperhead

  3. #13
    Luogo
    Lazio
    Post
    1,596
    Blogs
    21
    Quote Originariamente inviato da marco.santilli Visualizza il messaggio
    avete nuove idee per proseguire con i test e capire il problema?
    ciao e grazie
    se fai più chiamate consecutive è lenta sola la prima ?



    (...Usedefaultproxy=false)
    Ciao sspintux
    ------------------------------------------------------------

    O Santo Protettore dell'informatico quadratico medio, se puoi allontana da me questo cetriolo amaro!
    Azz! ... questo è un grande porck-around; potremmo addirittura farlo passare per una funzionalità avanzata

  4. #14
    L'avatar di bumm
    bumm non è in linea Very Important Person Ultimo blog: [VB2010] ComboBox ed Enumeratori
    Luogo
    Bologna
    Post
    2,142
    Blogs
    1
    Quote Originariamente inviato da marco.santilli Visualizza il messaggio
    non ci sono query lente...
    quindi il problema è sui ws, sulla restituzione dei dati...
    la connessione ai ws avviene attraverso indirizzo ip e non nome macchina...

    avete nuove idee per proseguire con i test e capire il problema?
    ciao e grazie
    a questo punto bisogna spostare la discussione. non ha niente a che fare con MySql.
    "HeloWorld.exe" 17 errors, 31 warnings.

    Non mi mandate le richieste di aiuto via PM! Non vi risponderò! Tutte le domande fateli sul forum!

  5. #15
    marco.santilli non è in linea Scolaretto
    Post
    443

    ok

    Quote Originariamente inviato da sspintux Visualizza il messaggio
    se fai più chiamate consecutive è lenta sola la prima ?



    (...Usedefaultproxy=false)

    tutte lente...dalla prima all'ultima...
    sia in rete cablata (Gbit) sia in Wifi, sia virtualizzata con bridge..

    usiamo come motore: CASSINI
    UltiDev - The Server Software Company Bridging Web and Local Networks

    volevo provare con IIS giusto per fare un test
    i7 3770K --- Asus P8z77 --- 2x4Gb Corsair Vengeance 2133MHz--- Enermax NoiseTaker II 600w --- SSD: 128Gb Vertex 4 --- WD 1000Gb --- WD 2000Gb --- ASUS ATI5850 1Gb --- Case: Kandalf 25cm Fan --- Tastiera Logitech G15 --- Mouse Razer Copperhead

  6. #16
    marco.santilli non è in linea Scolaretto
    Post
    443

    ok

    Ci siamo..ci siamo...ci siamo.....

    Fatto test usando IIS e non CASSINI, tutto vola adesso, anche i pc in remoto sono velocissimi....

    ora però dovrei capire perchè CASSINI fa cosi, se ci sono settaggi particolari da utilizzare....
    i7 3770K --- Asus P8z77 --- 2x4Gb Corsair Vengeance 2133MHz--- Enermax NoiseTaker II 600w --- SSD: 128Gb Vertex 4 --- WD 1000Gb --- WD 2000Gb --- ASUS ATI5850 1Gb --- Case: Kandalf 25cm Fan --- Tastiera Logitech G15 --- Mouse Razer Copperhead

  7. #17
    L'avatar di +m+
    +m+
    +m+ non è in linea Scribacchino
    Post
    922
    Non so quasi nulla di Cassini, ma sembra una sorta di VPN-over-http.
    Che aggiunga una caterva di latenza mi pare abbastanza naturale

  8. #18
    marco.santilli non è in linea Scolaretto
    Post
    443

    ok

    Quote Originariamente inviato da +m+ Visualizza il messaggio
    Non so quasi nulla di Cassini, ma sembra una sorta di VPN-over-http.
    Che aggiunga una caterva di latenza mi pare abbastanza naturale
    IIS è una bomba ma trovo difficoltà nell'istallazione ed esecuzione tutto in automatico su diverse piattaforme
    XP
    win 7
    win 8
    win 8.1
    win 10

    ognuno ha un configurazione leggermente diverse che non mi permettere di fare uno script uguale e funzionale per tutti..

    si può fare uno script che vada bene per tutti?????

    risolto questo sono apposto su tutto...

    ciao e grazie
    i7 3770K --- Asus P8z77 --- 2x4Gb Corsair Vengeance 2133MHz--- Enermax NoiseTaker II 600w --- SSD: 128Gb Vertex 4 --- WD 1000Gb --- WD 2000Gb --- ASUS ATI5850 1Gb --- Case: Kandalf 25cm Fan --- Tastiera Logitech G15 --- Mouse Razer Copperhead

+ Rispondi al Thread
Pagina 2 di 2 primaprima 12

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi