+ Rispondi al Thread
Visualizzazione dei risultati da 1 a 2 su 2

Discussione: Windows 10: Partizioni dei dischi - eliminare flag "partizione di sistema"

  1. #1
    fabrizio.monti non è in linea Scolaretto
    Luogo
    Provincia di Torino
    Post
    129

    Windows 10: Partizioni dei dischi - eliminare flag "partizione di sistema"

    Buongiorno.

    https://imgur.com/a/N6kpG

    Per prima cosa ho voluto postare il link alla immagine della Gestione disco del mio pc, al fine di meglio far comprendere di cosa sto parlando e di cosa ho bisogno.

    Come potete vedere il sistema si compone di un SSD (disco 1) -C- che ospita il sistema operativo Windows 10;

    poi ci sono due hard disk interni: (disco 0) -E- e (disco 2) -D- che sono adibiti esclusivamente a dati e ad alcuni programmi (programmi solo in D);

    infine un hard disk esterno (disco 3) -P- adibito ai backup (di dati).

    Finora questa configurazione (che ora temo di capire non sia corretta) ha funzionato senza apparenti problemi.
    Anticamente (prima della installazione nel sistema del SSD) il disco 0 ("E", che in quel tempo antico si chiamava "C", poi gli ho cambiato nome) ospitava il sistema operativo.

    Quando ho installato il SSD ho reinstallato il sistema operativo su quel disco e l'ho chiamato "C", mentre il vecchio "C" è diventato "E".

    Oggi mi accorgo che qualcosa non va per il verso giusto per due motivi che, messi insieme, hanno fatto accendere la lampadina (fioca) che ha rischiarato per un attimo la mia ignoranza:

    1 - qualche tempo fa volevo sostituire "E" con un più capiente hard drive da 2 TB, ma quando ho scollegato "E" e al posto suo ho messo il nuovo "E" (quello da 2TB) non c'e' stato più modo di far ripartire il pc. O meglio, per farlo ripartire ho dovuto togliere il nuovo "E" da 2 TB e rimettere al suo posto quello vecchio che volevo sostituire.

    Il perchè non lo compresi, in quel momento, mi limitai a prendere atto che senza il vecchio "E" il pc non si avviava (oggi comincio a sospettare che la cosa abbia a che fare con il fatto che "E" è flaggato come partizione di sistema...);

    2 - se tento di fare il backup del sistema utilizzando la funzione "backup sistema" di EaseUS Todo Backup, esso mi propone inscindibilmente il backup congiunto di C (presumo perchè sente che li c'e' il sistema operativo, o comunque perchè C è flaggato come disco di Avvio) e di E (presumo perchè, benchè al suo interno ci siano solo dati, esso è tuttavia flaggato come partizione di sistema);

    se il mio teorema è vero, allora capisco che l'attribuzione del flag "Sistema" a E non è corretta, ma .... come lo sistemo ?

    E qui, amici miei, ho bisogno del vostro sapiente aiuto, perchè da solo non me la cavo mi sa...

    Posso in qualche modo eliminare il flag "partizione di sistema" da E ? (senza dover però cancellare tutto?);

    se sì, posso poi attribuire tale flag (ammesso che sia necessario) a C, dove ora risiede effettivamente il sistema operativo ? (esso è già attualmente flaggato come "avvio");

    e in ultimo vi chiedo: è vero che (come sospetto) la porzione non allocata di C è troppo piccola ? Mi pare di aver capito, leggendo cose in giro, che essa dovrebbe essere di almeno il 10 % della capacità complessiva del disco ?

    Grazie per l'attenzione e confido che qualcuno mi sappia aiutare.

    Saluti a tutti.
    Fabrizio Monti

  2. #2
    fabrizio.monti non è in linea Scolaretto
    Luogo
    Provincia di Torino
    Post
    129

    Risolto

    Ciao ragazzi
    come da titolo ho RISOLTO la questione in autonomia.

    Quindi grazie lo stesso e anche se nessuno aveva ancora risposto informo chi volesse farlo che non è più necessario.

    Ho lavorato con i comandi DISKPART.

    Dapprima all'interno di Windows ho mano a mano selezionato come "inattiva" la partizione (unica) del disco E.
    Questo ha fatto sì che si trasformasse in "attiva" (e quindi di "sistema") la partizione (unica) del disco D.
    Sempre all'interno di Windows ho selezionato come "inattiva" anche quest'ultima. Dopodichè .... il computer non si è riavviato più !

    Quindi tramite disco di supporto all'installazione di Windows 10 (precedentemente creato con MEDIA CREATION TOOL) ho avviato il pc in modalità ripristino e tramite prompt dei comandi ho nuovamente utilizzato DISKPART per contrassegnare come "attiva" la partizione 1 di C (che contiene il sistema operativo).

    Al nuovo riavvio Windows nuovamente non si avviava, datosi che all'interno del nuovo disco di sistema/avvio (C) risultava mancante o corrotto il MBR.

    Quindi ho riavviato questa volta con Rescue Disk di Windows 10 e ho chiesto la "risoluzione dei problemi all'avvio" e ... eccomi qui a scrivere utilizzando il pc correttamente ripristinato e riconfigurato per quanto attiene alla gestione disco, che ora appare così:

    https://imgur.com/a/0wFlq

    E finalmente quando vado a impostare il backup di sistema all'interno di EaseUS Todo Backup esso mi propone solo più (come è giusto che sia) il salvataggio di C.

    Nella speranza possa essere utile a qualcun altro ho spiegato quanto sopra.
    Per me ha funzionato, ma io sono un dilettante, quindi se in realtà la procedura più formalmente corretta (o anche solo meno complicata) fosse stata un'altra, mi farebbe piacere se qualcuno la volesse spiegare e condividere.

    Grazie a tutti e saluti.

    Fabrizio Monti.

+ Rispondi al Thread

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi