+ Rispondi al Thread
Visualizzazione dei risultati da 1 a 9 su 9

Discussione: Non si installa SQL SERVER 2008 EXPRESS R2

  1. #1
    L'avatar di sistemista
    sistemista non è in linea Topo di biblioteca
    Luogo
    Prato
    Post
    2,285

    Non si installa SQL SERVER 2008 EXPRESS R2

    Ho provato ad installare SQL SERVER 2008 express R2 con Tools sul mio pc,ma non si installa.

    Sistema operativo: windows 7 ultimate 32 bit(ancora da attivare)

    Processore:Athlon II x4 645 3,1 Ghz quad-core

    Ram:1 banco da 2 GB,1333 Ghz

    Hard disk da 320 GB

    Programmi installati:Visual studio 2008 professional con Framework 3.5 sp1

    il tutto nuovo di pacca.

    Avvio l'installazione,controllo la configurazione dei requisiti ed è a posto,continua l'installazione
    e alla richiesta quale account usare ho scelto system(penso di aver fatto bene dato che è la prima volta che lo uso)l'installazione continua quando ad un certo punto dà errore
    il compilatore MOF non è in grado di connettersi al server WMI
    l'installazione continua ma fallisce in quanto non ha installato niente.
    Ora,dato che è la prima volta che uso sql server 2008 express,chiedevo se qualcuno può darmi
    una mano e se magari è capitato ad altri lo stesso problema.
    Grazie a chiunque voglia aiutarmi.
    Sono stato nella terra del terrore e dei Vampiri...la transilvania? No!..in Banca.
    A Lupara?Min***a...Tecnologia Sicula è!

  2. #2
    crisales1979 non è in linea Scolaretto
    Luogo
    Pisa
    Post
    66
    Quote Originariamente inviato da sistemista Visualizza il messaggio
    Ho provato ad installare SQL SERVER 2008 express R2 con Tools sul mio pc,ma non si installa.

    Sistema operativo: windows 7 ultimate 32 bit(ancora da attivare)

    Processore:Athlon II x4 645 3,1 Ghz quad-core

    Ram:1 banco da 2 GB,1333 Ghz

    Hard disk da 320 GB

    Programmi installati:Visual studio 2008 professional con Framework 3.5 sp1

    il tutto nuovo di pacca.

    Avvio l'installazione,controllo la configurazione dei requisiti ed è a posto,continua l'installazione
    e alla richiesta quale account usare ho scelto system(penso di aver fatto bene dato che è la prima volta che lo uso)l'installazione continua quando ad un certo punto dà errore

    l'installazione continua ma fallisce in quanto non ha installato niente.
    Ora,dato che è la prima volta che uso sql server 2008 express,chiedevo se qualcuno può darmi
    una mano e se magari è capitato ad altri lo stesso problema.
    Grazie a chiunque voglia aiutarmi.
    hai attivato l'utente amministratore? se si prova ad acedere come tale utente e fai l'installazione con l'utente amministratore... dovrebbe funzionare se è quello che penso... facci sapere

  3. #3
    L'avatar di sspintux
    sspintux non è in linea Very Important Person Ultimo blog: scriptsharp
    Luogo
    Lazio
    Post
    1,443
    Blogs
    14
    ...verifica anche che il servizio wmi sia attivo
    Ciao sspintux
    ------------------------------------------------------------

    O Santo Protettore dell'informatico quadratico medio, se puoi allontana da me questo cetriolo amaro!
    Azz! ... questo è un grande porck-around; potremmo addirittura farlo passare per una funzionalità avanzata

  4. #4
    L'avatar di sistemista
    sistemista non è in linea Topo di biblioteca
    Luogo
    Prato
    Post
    2,285
    Quote Originariamente inviato da sspintux Visualizza il messaggio
    ...verifica anche che il servizio wmi sia attivo
    Rispondo alla domanda dell'altro utente:
    Sono l'unico utente(oltre all'utente administrator nascosto)ed ho eseguito il setup come
    amministratore.
    Per sspintux:

    Da dove lo verifico?
    Sono stato nella terra del terrore e dei Vampiri...la transilvania? No!..in Banca.
    A Lupara?Min***a...Tecnologia Sicula è!

  5. #5
    L'avatar di sistemista
    sistemista non è in linea Topo di biblioteca
    Luogo
    Prato
    Post
    2,285
    Dunque,secondo quanto riportato dal link microsoft
    Hardware and Software Requirements for Installing SQL Server 2008 R2
    il problema sembra legato alla dimensione della ram che deve essere max di 1 GB,ora
    ho installato sul mio pc 2 GB,quindi,potrebbe essere questo il problema.
    Risulta a qualcuno?
    Sono stato nella terra del terrore e dei Vampiri...la transilvania? No!..in Banca.
    A Lupara?Min***a...Tecnologia Sicula è!

  6. #6
    L'avatar di sspintux
    sspintux non è in linea Very Important Person Ultimo blog: scriptsharp
    Luogo
    Lazio
    Post
    1,443
    Blogs
    14
    Quote Originariamente inviato da sistemista Visualizza il messaggio
    Dunque,secondo quanto riportato dal link microsoft
    Hardware and Software Requirements for Installing SQL Server 2008 R2
    il problema sembra legato alla dimensione della ram che deve essere max di 1 GB,ora
    ho installato sul mio pc 2 GB,quindi,potrebbe essere questo il problema.
    Risulta a qualcuno?
    non credo dipenda da questo;
    ...ho installato sqlserver express R2 (e buona parte degli altri prodotti express) sul win 7 home premium
    di casa con 4 gb di ram senza problemi tramite la web platform installer.

    Comunque cercando in rete sembra che anche altri hanno avuto un problema molto simile al tuo

    ...lo hanno segnalato come bug anche alla microsoft
    The MOF Compiler could not connect with the WMI server | Microsoft Connect

    se non ci accedi nell'unica soluzione proposta c'è un referimento a
    Aaron Bertrand : The XP SP3 / MSXML6 SP2 / SQL Server debacle

    .....vedi anche qui di seguito se ti trovi qualcosa di utile
    WMI Service cannot be started when installing SQL Server Denali CTP3
    SQL Server 2008 R2 Setup hangs at SqlEngineConfigAction_install_confignonrc_Cpu64 | Peter Holcroft

    HTH
    Ultima modifica di sspintux; 15-09-2011 23:56 
    Ciao sspintux
    ------------------------------------------------------------

    O Santo Protettore dell'informatico quadratico medio, se puoi allontana da me questo cetriolo amaro!
    Azz! ... questo è un grande porck-around; potremmo addirittura farlo passare per una funzionalità avanzata

  7. #7
    L'avatar di sistemista
    sistemista non è in linea Topo di biblioteca
    Luogo
    Prato
    Post
    2,285
    Ho provato a controllare se WMI era corrotto ma è tutto a posto
    dando il comando
    codice:
    winmgmt /salvagerepository
    la risposta è questa
    codice:
    Archivio WMI è coerente
    ho provato con la versione DENALI si è installato correttamente ed è andato tutto a posto,quindi,c'è qualcosa che impedisce l'installazione perchè anche se l'errore indica probabilmente WMI,secondo la risposta di Microsoft(nel post da te indicato,il primo)potrebbe essere un'altra la causa.

    Dato che prima era installato Visual studio e poi ho installato SQL Server,non vorrei che tra installazioni/Disinstallazioni fosse successo qualche casino,quindi,dato che quando mi picco
    vado fino in fondo alla questione,riformatto e faccio l'installazione come primo software
    e poi ci aggiorniamo.
    Grazie per il momento.
    Sono stato nella terra del terrore e dei Vampiri...la transilvania? No!..in Banca.
    A Lupara?Min***a...Tecnologia Sicula è!

  8. #8
    L'avatar di sistemista
    sistemista non è in linea Topo di biblioteca
    Luogo
    Prato
    Post
    2,285
    Tutto è bene quello che finisce bene.
    Probabilmente il problema risiedeva nel fatto che avevo installato Visual Studio prima di
    SQL SERVER EXPRESS R2 e non so perchè si era incasinato tutto.
    Ho riformattato e come prima installazione SQL SERVER EXPRESS R2 e così ho risolto.
    Ora installo Visual Studio 2008 Professional e vediamo che succede.
    Incrocio le dita(anche quelle dei piedi).
    Sono stato nella terra del terrore e dei Vampiri...la transilvania? No!..in Banca.
    A Lupara?Min***a...Tecnologia Sicula è!

  9. #9
    L'avatar di sistemista
    sistemista non è in linea Topo di biblioteca
    Luogo
    Prato
    Post
    2,285
    Confermo che anche l'installazione di visual studio è andata a buon fine e quindi sia
    SQL SERVER EXPRESS 2008 R2 che VISUAL STUDIO 2008 funzionano bene entrambi.
    Caso risolto.
    Sono stato nella terra del terrore e dei Vampiri...la transilvania? No!..in Banca.
    A Lupara?Min***a...Tecnologia Sicula è!

+ Rispondi al Thread

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi