+ Rispondi al Thread
Visualizzazione dei risultati da 1 a 2 su 2

Discussione: [Ubuntu] Networking non funzionante dopo migrazione disco

  1. #1
    net-addiction non è in linea Scolaretto
    Luogo
    Treviso
    Post
    476

    [Ubuntu] Networking non funzionante dopo migrazione disco

    Buongiorno,
    ho una situazione un po' surreale.
    Ho dovuto spostare un disco con Ubuntu da una macchina ad un'altra. Funziona tutto tranne la rete.

    Se vado nel "network-manager" imposto per il device enp3s0 un IP fisso ma non trovo riscontro con ifconfig.
    Se eseguo "dhclient" lo stesso device prende un IP dal router che, chiaramente, è diverso da quello impostato in network-manager.

    Dopo l'esecuzione di "dhclient" tutto funziona ma al riavvio si ricomincia da capo. Avete idee su come fissare 'sto benedetto IP?

    Grazie,
    - The user formerly known as GRiM[R]eaPeR -

  2. #2
    net-addiction non è in linea Scolaretto
    Luogo
    Treviso
    Post
    476
    Ho risolto parlandone con un amico.
    Nelle ultime versioni di Ubuntu, la rete viene configurata con netplan grazie ad un file *.yaml in /etc/netplan.
    Quando si fa un'operazione tipo quella che ho fatto io (spostare un disco su un altro pc) il nome dell'interfaccia cambia.

    Banalmente basta verificare ed eventualmente correggere, facendo in modo che il nome dell'interfaccia all'interno del file /etc/netplan/*.yaml sia uguale all'interfaccia che vedete eseguendo
    codice:
    ifconfig -a
    .

    ciao
    - The user formerly known as GRiM[R]eaPeR -

+ Rispondi al Thread

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi