+ Rispondi al Thread
Pagina 2 di 2 primaprima 12
Visualizzazione dei risultati da 11 a 18 su 18

Discussione: Funzione SE con testo e riferimento dinamico al valore di una cella

  1. #11
    L'avatar di AntonioG
    AntonioG non è in linea Moderatore Globale Ultimo blog: Commodore 64 e Codemotion
    Luogo
    Roma
    Post
    16,939
    Blogs
    5
    Non hai seguito quello che ti ho detto. Nell'esempio in cui hai l'errore ci sono troppi parametri.

    Hai scritto che se A1=5

    allora mostra il testo "testo di prova "&A11
    altrimenti mostra il testo " ";

    L'altro SE è in più.

    Quindi, forse non volevi inserire il " "; ? Volevi forse scrivere

    =SE(A1=10;"testo di prova "&A11;SE(A1=5;"testo di prova "&A11;" "))

    ?
    Avvisi generali e importanti, a pena CHIUSURA thread e/o BAN
    Il crossposting è vietato.
    Le richieste di "pappa pronta" sono vietate.
    Utilizzate i tag CODE per il codice.
    Leggere il Regolamento per chiarimenti PRIMA di creare nuovi thread.
    Utilizzare sempre i PM per comunicare con i moderatori.
    Non mi contattate in PM per problemi di software, usate il forum

  2. #12
    Pika81 non è in linea Novello
    Post
    10
    Antonio, funziona perfettamente...
    Non avevo compreso l'errore.

    Grazie 1000

  3. #13
    Pika81 non è in linea Novello
    Post
    10
    Ciao a tutti, ritorno sull'argomento per un ultima specifica...

    Data la funzione suggerita da Antonio:

    =SE(A1=10;"testo di prova "&A11;SE(A1=5;"testo di prova "&A11;" "))

    È possibile inserire il riferimento alla cella A11 all'interno del testo citato anziche alla fine?
    Per capirci:

    "Testo &A11 testo"

    Grazie
    M

  4. #14
    L'avatar di AntonioG
    AntonioG non è in linea Moderatore Globale Ultimo blog: Commodore 64 e Codemotion
    Luogo
    Roma
    Post
    16,939
    Blogs
    5
    Non hai studiato dal link l'operatore & ... non va bene

    Penso proprio che tu possa riuscirci se ci provi anche senza forum
    Avvisi generali e importanti, a pena CHIUSURA thread e/o BAN
    Il crossposting è vietato.
    Le richieste di "pappa pronta" sono vietate.
    Utilizzate i tag CODE per il codice.
    Leggere il Regolamento per chiarimenti PRIMA di creare nuovi thread.
    Utilizzare sempre i PM per comunicare con i moderatori.
    Non mi contattate in PM per problemi di software, usate il forum

  5. #15
    Pika81 non è in linea Novello
    Post
    10
    in realta non ho avuto il tempo di leggerlo approfonditamente, se la risposta è li la troverò!

  6. #16
    L'avatar di AntonioG
    AntonioG non è in linea Moderatore Globale Ultimo blog: Commodore 64 e Codemotion
    Luogo
    Roma
    Post
    16,939
    Blogs
    5
    Il tempo su deve trovare se si vuole imparare, altrimenti sembra che si voglia la pappa pronta. Non basta il forum.

    Hai tre parti

    "Testo " A11 " testo"

    e ti è stato detto di usare l'operatore &

    Ora mettici un minimo di tuo
    Avvisi generali e importanti, a pena CHIUSURA thread e/o BAN
    Il crossposting è vietato.
    Le richieste di "pappa pronta" sono vietate.
    Utilizzate i tag CODE per il codice.
    Leggere il Regolamento per chiarimenti PRIMA di creare nuovi thread.
    Utilizzare sempre i PM per comunicare con i moderatori.
    Non mi contattate in PM per problemi di software, usate il forum

  7. #17
    Pika81 non è in linea Novello
    Post
    10
    Lungi da me cercare la pappa pronta.....

    =SE(A1=10;"testo di prova "&A11 &" testo";SE(A1=5;"testo di prova "&A10 &" testo"))

    Risolto!
    Grazie 1000

    M

  8. #18
    L'avatar di AntonioG
    AntonioG non è in linea Moderatore Globale Ultimo blog: Commodore 64 e Codemotion
    Luogo
    Roma
    Post
    16,939
    Blogs
    5
    Ne ero certo... A volte bisogna chiedere a se stessi un minimo di impegno in più
    Avvisi generali e importanti, a pena CHIUSURA thread e/o BAN
    Il crossposting è vietato.
    Le richieste di "pappa pronta" sono vietate.
    Utilizzate i tag CODE per il codice.
    Leggere il Regolamento per chiarimenti PRIMA di creare nuovi thread.
    Utilizzare sempre i PM per comunicare con i moderatori.
    Non mi contattate in PM per problemi di software, usate il forum

+ Rispondi al Thread
Pagina 2 di 2 primaprima 12

Tag per questa discussione

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi