+ Rispondi al Thread
Pagina 1 di 2 12 ultimoultimo
Visualizzazione dei risultati da 1 a 10 su 14

Discussione: controllo somma

  1. #1
    layla75 non è in linea Novello
    Post
    25

    controllo somma

    Buondi ragazzi ,nella colonna k ho una serie di valori ,devo effettuare una somma da k7 a kn ,ogni giorno in essa inserisco un valore
    K7 0,030430863
    K8 0,023617768
    ecc 0,031280336
    ecc 0,037248119
    0,031516985
    0,026180829
    0,024151904
    0,030924923
    0,025859584
    0,030644295
    0,019573389
    0,013270019
    0,025771027
    0,000000000 la somma dovrebbe fino a quando in k c'e' un valore ,precedente a 0,000000000
    0,000000000
    0,000000000
    #VALORE!
    #VALORE!
    #VALORE!
    #VALORE!
    #VALORE!
    KN #VALORE!

    speranzoso di essere stato chiaro ,
    grazie di una vostra

  2. #2
    L'avatar di AntonioG
    AntonioG non è in linea Moderatore Globale Ultimo blog: Commodore 64 e Codemotion
    Luogo
    Roma
    Post
    16,261
    Blogs
    5
    Anche se sommi 0,000 il risultato non cambia. Somma la colonna
    Avvisi generali e importanti, a pena CHIUSURA thread e/o BAN
    Il crossposting è vietato.
    Le richieste di "pappa pronta" sono vietate.
    Utilizzate i tag CODE per il codice.
    Leggere il Regolamento per chiarimenti PRIMA di creare nuovi thread.
    Utilizzare sempre i PM per comunicare con i moderatori.
    Non mi contattate in PM per problemi di software, usate il forum

  3. #3
    layla75 non è in linea Novello
    Post
    25
    Grazie per aver preso in esame la mia ...., non sono stato chiaro ad esprimermi ,
    la formula che ho scritto : =somma (K7:K197) e mi da la somma da 7 a 197
    il giorno dopo inserisco un valore in riga 198 e riscrivo la formula =somma(k7:k198) e mi da la somma da 7 a 198
    il giorno dopo inserisco un valore in riga 199 e riscrivo la formula =somma(k7:k199) e mi da la somma da 7 a 199
    e cosi tutti i giorni , alla fine dell'anno l'ultima sara'=somma(k7:k371)
    se scrivo =somma(k7:k371) mi da l'errore #valore! ,
    desiderei trovare un modo di dire fammi la somma da k7 a k371 ,fermandoti prima che trovi in k 0,000000000, oppure fammi la somma da k7:k371 non tenendo conto #VALORE!

    esempio
    k196 0,019573389
    k197 0,013270019
    k198 0,025771027
    k199 0,000000000
    k200 0,000000000
    k201 0,000000000
    k202 #VALORE!
    k203 #VALORE!

  4. #4
    Sgrubak non è in linea Scolaretto
    Luogo
    Torrazza Piemonte
    Post
    301
    Quote Originariamente inviato da layla75 Visualizza il messaggio
    ...il giorno dopo inserisco un valore in riga 198...
    Desumo dal fatto che l'aiuto di Antonio non ti abbia giovato, che tu il valore non lo inserisca nella cella della colonna K (altrimenti non avresti l'errore). Ergo: sfrutta il suggerimento di Antonio modificando la formula così:
    codice:
    =SOMMA(K7:K371)
    e poi gestisci l'errore nella colonna K sfruttando la formula:
    codice:
    =SE.ERRORE([FormulaDaValutare];0)
    Così elimini l'errore alla radice.

  5. #5
    Ferrari_and non è in linea Scolaretto
    Post
    113
    codice:
    =SOMMA.SE(K7:k5000;"<>")
    Fa la somma di tutte le celle che contengono valori attenzioni anche non numerici

  6. #6
    Sgrubak non è in linea Scolaretto
    Luogo
    Torrazza Piemonte
    Post
    301
    Non risolve il problema... L'errore se lo porta dietro lo stesso. Lui vuole ottenere la somma senza gli errori e la maniera più agevole è rimuovere l'errore nella colonna K, Per usare il [SOMMA.SE] dovrebbe sfruttare un'altra colonna in appoggio, dove valuta il tipo restituito in K e lo somma solo se è numerico.

  7. #7
    Ferrari_and non è in linea Scolaretto
    Post
    113
    sorry dimenticato un pezzo
    codice:
    =SOMMA.SE(K7:k5000;"<>#VALORE!")
    dovrebbe funzionare

  8. #8
    layla75 non è in linea Novello
    Post
    25
    Grazie x l'aiuto ...
    1-=SOMMA.SE(K7:k5000;"<>") mi scrive #valore!
    2-=SOMMA.SE(K7:k5000;"<>#VALORE forse manca o qualcosa in piu' mi esce una mascherina in cui dice
    " La formula contiene un errore . Provare ecc ecc "

    Risolto modificando la formula nella colonna k =0,0833333*F(n) n da 7 a 371

    3 - =se.errore(0,0833333*F7;0) e copiando da k7 fino a k371

  9. #9
    Sgrubak non è in linea Scolaretto
    Luogo
    Torrazza Piemonte
    Post
    301
    Quote Originariamente inviato da layla75 Visualizza il messaggio
    ...forse manca o qualcosa...
    La formula corretta sarebbe
    codice:
    =SOMMA.SE(K7:k5000;"<>#VALORE!")
    Bisogna aggiungere il punto esclamativo, chiudere i doppi apici e poi la parentesi tonda. Ho fatto un test e funziona.

  10. #10
    layla75 non è in linea Novello
    Post
    25
    Grazie funziona ....
    SOMMA.SE(K7:K5000;"<>#VALORE!")
    con l'aggiunta punto esclamativo ,chiudere i doppi apici e parentesi rotonda
    Ultima modifica di layla75; 12-07-2019 16:58 

+ Rispondi al Thread
Pagina 1 di 2 12 ultimoultimo

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi