+ Rispondi al Thread
Visualizzazione dei risultati da 1 a 7 su 7

Discussione: Problema apertura progetto

  1. #1
    L'avatar di systemgvp
    systemgvp non è in linea Scribacchino
    Post
    565

    Problema apertura progetto

    Ciao a tutti,

    ieri finito il lavoro ho compilato e salvato il mio progetto e tutto funzionava bene.
    Oggi, quando tento di aprire il progetto ottengo questo errore!

    Cattura.PNG

    perchè?

    ieri funzionava tutto senza problemi!

    uso FireMonkey e nessun componente di terze parti o database
    Ultima modifica di systemgvp; 16-03-2017 16:09 
    Embarcadero RAD Studio 10.1 Berlin - con Pascal dal 1992

  2. #2
    L'avatar di _alka_
    _alka_ non è in linea Very Important Person
    Luogo
    Reggio Emilia
    Post
    1,042
    Hai installato qualche nuovo tool all'interno dell'IDE di Delphi?
    MARCO BREVEGLIERI
    Software and Web Developer, Teacher and Consultant

    Homepage | Blog | Delphi Podcast | Delphi Succinctly (e-book)

  3. #3
    L'avatar di systemgvp
    systemgvp non è in linea Scribacchino
    Post
    565
    Niente di niente purtroppo!
    Embarcadero RAD Studio 10.1 Berlin - con Pascal dal 1992

  4. #4
    L'avatar di systemgvp
    systemgvp non è in linea Scribacchino
    Post
    565
    Però entrambe i computer che uso hanno Windows 10 è ieri c'è stato un aggiornamento, e l'errore me lo da su entrambe. Ho provato su altri progetti sia ad aprirli che a farne di nuovi, ma funzionano tutti.
    Embarcadero RAD Studio 10.1 Berlin - con Pascal dal 1992

  5. #5
    L'avatar di systemgvp
    systemgvp non è in linea Scribacchino
    Post
    565
    Per chi ne avesse bisogno ho risolto in questo modo

    1. Ho creato un nuovo progetto vuoto con lo stesso nome.
    2. Ho aperto il file .DPROJ
    3. Ho incollato tutto il contenuto della sezione <ItemGroup></ItemGroup>
    4. Ho aperto il progetto e ricaricato le informazioni versione e icone

    è una forzatura del sistema, ma ha funzionato. Comunque ancora non capisco dov'era il problema.
    Embarcadero RAD Studio 10.1 Berlin - con Pascal dal 1992

  6. #6
    L'avatar di _alka_
    _alka_ non è in linea Very Important Person
    Luogo
    Reggio Emilia
    Post
    1,042
    Quote Originariamente inviato da systemgvp Visualizza il messaggio
    Per chi ne avesse bisogno ho risolto in questo modo

    1. Ho creato un nuovo progetto vuoto con lo stesso nome.
    2. Ho aperto il file .DPROJ
    3. Ho incollato tutto il contenuto della sezione <ItemGroup></ItemGroup>
    4. Ho aperto il progetto e ricaricato le informazioni versione e icone

    è una forzatura del sistema, ma ha funzionato. Comunque ancora non capisco dov'era il problema.
    Difficile dirlo senza poter fare delle prove o vedere il problema in diretta sul file.

    Effettivamente in questi casi la soluzione migliore è quella di ricreare da zero, trasferire tutto quello che risulta indispensabile e lasciare a Delphi il compito di aggiungere il resto. Magari questo ha escluso l'inserimento di un elemento diventato obsoleto o valorizzato con qualcosa di non interpretabile da una determinata API... chi può dirlo.
    MARCO BREVEGLIERI
    Software and Web Developer, Teacher and Consultant

    Homepage | Blog | Delphi Podcast | Delphi Succinctly (e-book)

  7. #7
    L'avatar di systemgvp
    systemgvp non è in linea Scribacchino
    Post
    565
    Misteri. . . . .!
    Embarcadero RAD Studio 10.1 Berlin - con Pascal dal 1992

+ Rispondi al Thread

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi