+ Rispondi al Thread
Pagina 4 di 5 primaprima ... 2345 ultimoultimo
Visualizzazione dei risultati da 31 a 40 su 42

Discussione: Problema con query

  1. #31
    ettorpa non è in linea Novello
    Post
    28
    Grazie mille Birbyyyyyyyyyy,
    Ma come dicevo anche a sspintux,
    Ho provato la tua nuova query e anche questa funziona bensissimo...ma non riesco a capire perchè i 3 campi: (prezzomin,prezzomed,prezzomax) hanno sempre valori identici su tutti i record.
    In effetti LA QUERY estrae i risultati dei prezzi (min,med,max) solo per quel record specifico e non analizza/confronta tutti gli altri record.

    esempio: (quello che succede ora)

    Pzmin Pzmed Pzmax

    2,60 2,60 2,60

    Esempio: (quello che dovrebbe fare in base a tutti i codici estratti)
    Pzmin Pzmed Pzmax

    2,60 3,20 4,50

  2. #32
    ettorpa non è in linea Novello
    Post
    28
    Inzio a preoccuparmi forse non riesco ad esprimermi bene e a farmi capire del tutto.

  3. #33
    Luogo
    Lazio
    Post
    1,599
    Blogs
    21
    Quote Originariamente inviato da ettorpa Visualizza il messaggio
    Inzio a preoccuparmi forse non riesco ad esprimermi bene e a farmi capire del tutto.
    ... riporta *per intero e fedelmente* le query che hai provato in access
    (... le hai provate direttamente in access sostituendo % con * come ti aveva suggerito byrby, vero ?)
    Ciao sspintux
    ------------------------------------------------------------

    O Santo Protettore dell'informatico quadratico medio, se puoi allontana da me questo cetriolo amaro!
    Azz! ... questo è un grande porck-around; potremmo addirittura farlo passare per una funzionalità avanzata

  4. #34
    L'avatar di birby
    birby non è in linea Scolaretto
    Luogo
    Brescia
    Post
    124
    Scusami ma adesso dobbiamo proprio intenderci, altrimenti non ci capiamo.
    La query che ti ho postato fa il suo dovere; uno dei record che estrae, ad esempio è questo (ho omesso solo i campi <grammi_sea> e <grammi_con>):
    codice:
    code		code_oem	description						price	xnote	minimo	medio	massimo
    F300SA1510	ML-1510D3	DRUM FOR SAMSUNG ML 1510, 1520, 1520P, 1710B, 1710	2,86		2,6	3,01	3,68
    dove, come puoi vedere, i campi minimo medio e massimo sono diversi.
    Le query che ti avevo postato precedentemente, includevano dei campi (concorrente, prezzo concorrenza, ID) che non consentivano di ottenere il risultato voluto..
    Ora, direi che da questo punto fermo devi ripartire ... un conto è la query un'altra storia è il codice ASP che usi.

  5. #35
    ettorpa non è in linea Novello
    Post
    28
    Grazie mille ragazzi per la pazienza.

    Allora forse c'è qualcosa che non va nel codice...devo ricontrollare tutto.

    Birby ma ti ha estratto più record con F300SA1510??? e tutti con valori diversi?

    Se è cosi...allora funziona a dovere.

    Magari me la provo anche in access (cosa che non ho ancora fatto.)

  6. #36
    ettorpa non è in linea Novello
    Post
    28
    Vi ringrazioooooooooooooooooo

  7. #37
    ettorpa non è in linea Novello
    Post
    28
    Hai ragione birby, l'ho provata in access e funziona a meraviglia.

    Allora devo controllare bene il codice ASP...c'è qualcosa che non torna.

    Grazie per tutto...e scusatemi se vi ho stressato ulteriormente...dato anche il periodo

  8. #38
    ettorpa non è in linea Novello
    Post
    28
    CRIBBIO!!!!!!

    Il problema era banalissimo....che cretino che sono stato.

    Era semplicemente sbagliata la path (con tutte le prove e le pagine rinominate...era il minimo che potesse accadere)

    In effetti quando cliccavo sul submit, puntava a tutt'altra pagina e non alla stessa.

    Grazie mille ragazzi per avermi fatto riflettere e capire... e per la pazienza dimostratami.

    Grazieeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee

  9. #39
    L'avatar di birby
    birby non è in linea Scolaretto
    Luogo
    Brescia
    Post
    124
    Quote Originariamente inviato da ettorpa Visualizza il messaggio
    CRIBBIO!!!!!!

    Il problema era banalissimo....che cretino che sono stato.

    Era semplicemente sbagliata la path (con tutte le prove e le pagine rinominate...era il minimo che potesse accadere)

    In effetti quando cliccavo sul submit, puntava a tutt'altra pagina e non alla stessa.

    Grazie mille ragazzi per avermi fatto riflettere e capire... e per la pazienza dimostratami.

    Grazieeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee
    Bene!
    Buon lavoro .... e adesso fammi andare in ferie tranquillo !!!!
    Ciao


  10. #40
    ettorpa non è in linea Novello
    Post
    28
    Buone ferie Birby e non pensare alle mie query per carità

+ Rispondi al Thread
Pagina 4 di 5 primaprima ... 2345 ultimoultimo

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi