+ Rispondi al Thread
Visualizzazione dei risultati da 1 a 3 su 3

Discussione: Inserire Progetto asp.net in rete lan

  1. #1
    sanfra non è in linea Scolaretto
    Post
    373

    Inserire Progetto asp.net in rete lan

    salve, ho bisogno del vostro aiuto, perchè non riesco a configurare IIS 5.1 per mettere un progetto fatto in asp.net 2.0 con visual studio 2008, c#.net, sql server 2005 express edition.

    I passaggi che ho fatto fin'ora sono stati confusionari e senza capire molto delle procedure da me attuate.

    Ho creato questo progetto in modalità file system, quindi dentro C del mi pc ho una cartella X e dentro ho tutti i miei file, compresi i db(miodb.mdf e aspnetdb.mdf),quest'ultimo per l'autenticazione degli utenti.


    Ho creato una directory virtuale e sono riusciuto a collegami tramite il mio web browser inserendo il mio indirizzo IP e il nome della directory e mi appare correttamente la pagine di login, però quando vado a fare il login mi dice:

    Errore server nell'applicazione '/sedeugl'.
    --------------------------------------------------------------------------------

    Errore di configurazione.
    Descrizione: Si è verificato un errore durante l'elaborazione di un file di configurazione necessario per soddisfare la richiesta. Verificare i dettagli dell'errore specifico riportati di seguito e modificare il file di configurazione in modo appropriato.

    Messaggio di errore del parser: Il nome della connessione 'LocalSqlServer' non è stato trovato nella configurazione delle applicazioni o la stringa di connessione è vuota.

    Errore nel codice sorgente:


    Riga 147: <roleManager>
    Riga 148: <providers>
    Riga 149: <add name="AspNetSqlRoleProvider" connectionStringName="LocalSqlServer" applicationName="/" type="System.Web.Security.SqlRoleProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
    Riga 150: <add name="AspNetWindowsTokenRoleProvider" applicationName="/" type="System.Web.Security.WindowsTokenRoleProvider , System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
    Riga 151: </providers>


    File di origine: c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Conf ig\machine.config Riga: 149


    --------------------------------------------------------------------------------
    Informazioni di versione: Versione di Microsoft .NET Framework:2.0.50727.3082; Versione di ASP.NET:2.0.50727.3082
    Mi potete aiutare a farlo funzionare?

    Grazie

  2. #2
    dan1987 non è in linea Scolaretto
    Post
    138
    dovresti prima cosa provare a configurare il sito creando un nuovo web site su iis e non una virtual directory dato che probabilmente non hai messo i file sotto inetpub\www.root...
    in più dovresti controllare le permission su iis che siano corrette (se stai usando ad esempio che tipo di autenticazione usi e che utente è configurato su iis e quali sono i suoi permessi.
    e infine prova a ricontrollare la stringa di connessione nel web.config

  3. #3
    ikki83 non è in linea Novello
    Post
    2
    io ho un problema simile. Ho realizzato un sito in asp.net e sul mio portatile funziona benissimo.
    però se cerco di collegarmi dal pc fisso o dal palmare (che sono collegati alla stessa rete wifi del portatile) mi dà sempre errore.
    Sapete dirmi perchè?

+ Rispondi al Thread

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi