+ Rispondi al Thread
Pagina 1 di 2 12 ultimoultimo
Visualizzazione dei risultati da 1 a 10 su 11

Discussione: Errore Server Error in '/' Application.

  1. #1
    massimoflorian non è in linea Scolaretto
    Post
    267

    Errore Server Error in '/' Application.

    Salve ragazzi, ho realizzato delle paginette in aspnet con collegamento al database e li ho pubblicate su n server aruba. Non capisco mi da il seguente errore:
    non capisco di cosa si tratta....
    Qualcuno può aiutarmi?
    Grazie come sempre anticipatamente.
    <!-- Web.Config Configuration File --><configuration> <system.web> <customErrors mode="Off"/> </system.web></configuration>
    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File --><configuration> <system.web> <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/> </system.web></configuration>

  2. #2
    L'avatar di SignIn
    SignIn non è in linea Scribacchino
    Luogo
    Milano
    Post
    1,026
    Ciao
    1)con quale Framework hai costruito la tua web application? (1.1, 2.0, 3.5 )
    2)l'errore ti compare solo sul server di hosting o anche sulla macchina di sviluppo?
    3)se compare solo sulla macchina di hosting hai verificato/chiesto in iis quale versione di Asp.Net è settata per la tua web application?

    Infine dai un occhio a questa
    discussione

  3. #3
    massimoflorian non è in linea Scolaretto
    Post
    267
    ciao SignIn.
    la mia applicazione è realizzata con visual studio 2008 Framework3.5.
    L'error sul mio computer non mi compare.
    L'errore si verifica quando invio tutto sul provider aruba.
    Tra l'altro aruba mi ha comunicato da poco che adesso lavora con frammework 3.5.
    Per il settaggio che mi chiedi tu credo che in automatico non lavora con
    Framework3.5. ?
    Ciao grazie per il tuo intervento.

  4. #4
    massimoflorian non è in linea Scolaretto
    Post
    267
    comunque ho fatto un test e la versione di iis è server softwareVersione di IIS: Microsoft-IIS/6.0



    il mio computer va con vista home edition

  5. #5
    L'avatar di SignIn
    SignIn non è in linea Scribacchino
    Luogo
    Milano
    Post
    1,026
    Ciao massimo,
    quello che ti chiedevo nel punto 3 è verificare non tanto in locale, ma sul server (presumo però che accedi solo ad una cartella tramite protocollo FTP) in:
    Pannello di controllo > Strumenti di amministrazione > Internet Information Services > seleziona la tua web application > tasto destro Proprietà > Tab Asp.Net > Asp.Net version deve essere impostato su 2.0
    Hai già aperto un ticket su aruba?

  6. #6
    massimoflorian non è in linea Scolaretto
    Post
    267
    Sign In la verifica che ho fatto è proprio sul server.

    Versione di IIS: Microsoft-IIS/6.0

    il mio computer con il sistema operativo vista home edition non ha installato iis penso.
    HO CONTROLLATO QUELLA DISCUSSIONE DI CUI MI HAI INVIATO IL LINK MA NON RIESCO A CAPIRE COSA POTREBBE SUCCEDERE. AVENDO LORO IL FRAMWORK 3.5 NON DOVREBBE FUNZIONARE LA MIA APPLICAZIONE?
    NON CAPISCO....

    il mio file web.config è il seguente:
    <?xml version="1.0"?>
    <!--
    Nota: come alternativa alla modifica manuale del file, è possibile utilizzare lo
    strumento di amministrazione Web per configurare le impostazioni dell'applicazione. Utilizzare il comando
    Configurazione ASP.NET del menu Sito Web di Visual Studio.
    Un elenco completo di impostazioni e commenti è disponibile nel file
    machine.config.comments che si trova in genere in
    \Windows\Microsoft.Net\Framework\v2.x\Config
    -->
    <configuration>
    <configSections>
    <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensions SectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
    <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGro up, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
    <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptReso urceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
    <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebService sSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
    <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerial izationSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="Everywhere"/>
    <section name="profileService" type="System.Web.Configuration.ScriptingProfileSer viceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
    <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthentica tionServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
    <section name="roleService" type="System.Web.Configuration.ScriptingRoleServic eSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
    </sectionGroup>
    </sectionGroup>
    </sectionGroup>
    </configSections>
    <appSettings/>
    <connectionStrings>
    <add name="databaseConnectionString" connectionString="Provider=Microsoft.Jet.OLEDB.4.0 ;Data Source=|DataDirectory|\database.mdb;Persist Security Info=True" providerName="System.Data.OleDb"/>
    </connectionStrings>
    <system.web>
    <!--
    Impostare compilation debug="true" per inserire i
    simboli di debug nella pagina compilata. Poiché tale operazione ha effetto
    sulle prestazioni, impostare questo valore su true
    solo durante lo sviluppo.

    Opzioni di Visual Basic:
    Impostare strict="true" per impedire qualsiasi conversione di tipi di dati
    in caso di possibile perdita di dati.
    Impostare explicit="true" per imporre la dichiarazione di tutte le variabili.
    -->
    <compilation debug="true" strict="false" explicit="true">
    <assemblies>
    <add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
    <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    <add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
    <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
    <add assembly="Microsoft.ReportViewer.WebForms, Version=9.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
    <add assembly="Microsoft.ReportViewer.Common, Version=9.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
    </assemblies>
    <buildProviders>
    <add extension=".rdlc" type="Microsoft.Reporting.RdlBuildProvider, Microsoft.ReportViewer.Common, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
    </buildProviders>
    </compilation>
    <pages>
    <namespaces>
    <clear/>
    <add namespace="System"/>
    <add namespace="System.Collections"/>
    <add namespace="System.Collections.Generic"/>
    <add namespace="System.Collections.Specialized"/>
    <add namespace="System.Configuration"/>
    <add namespace="System.Text"/>
    <add namespace="System.Text.RegularExpressions"/>
    <add namespace="System.Linq"/>
    <add namespace="System.Xml.Linq"/>
    <add namespace="System.Web"/>
    <add namespace="System.Web.Caching"/>
    <add namespace="System.Web.SessionState"/>
    <add namespace="System.Web.Security"/>
    <add namespace="System.Web.Profile"/>
    <add namespace="System.Web.UI"/>
    <add namespace="System.Web.UI.WebControls"/>
    <add namespace="System.Web.UI.WebControls.WebParts"/>
    <add namespace="System.Web.UI.HtmlControls"/>
    </namespaces>
    <controls>
    <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
    <add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
    </controls>
    </pages>
    <!--
    La sezione <authentication> consente di configurare
    la modalità di autenticazione della sicurezza utilizzata da
    ASP.NET per identificare un utente in ingresso.
    -->
    <authentication mode="Windows"/>
    <!--
    La sezione <customErrors> consente di configurare
    l'operazione da eseguire in caso di errore non gestito
    durante l'esecuzione di una richiesta. In particolare,
    consente agli sviluppatori di configurare le pagine di errore HTML
    in modo che vengano visualizzate al posto dell'analisi dello stack dell'errore.

    <customErrors mode="RemoteOnly" defaultRedirect="GenericErrorPage.htm">
    <error statusCode="403" redirect="NoAccess.htm" />
    <error statusCode="404" redirect="FileNotFound.htm" />
    </customErrors>
    -->
    <httpHandlers>
    <remove path="*.asmx" verb="*" />
    <add path="*.asmx" verb="*" type="System.Web.Script.Services.ScriptHandlerFact ory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"
    validate="false" />
    <add path="*_AppService.axd" verb="*" type="System.Web.Script.Services.ScriptHandlerFact ory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"
    validate="false" />
    <add path="ScriptResource.axd" verb="GET,HEAD" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"
    validate="false" />
    <add path="Reserved.ReportViewerWebControl.axd" verb="*" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"
    validate="false" />
    </httpHandlers>
    <httpModules>
    <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
    </httpModules>
    </system.web>
    <system.codedom>
    <compilers>
    <compiler language="c#;cs;csharp" extension=".cs" warningLevel="4" type="Microsoft.CSharp.CSharpCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
    <providerOption name="CompilerVersion" value="v3.5"/>
    <providerOption name="WarnAsError" value="false"/>
    </compiler>
    <compiler language="vb;vbs;visualbasic;vbscript" extension=".vb" warningLevel="4" type="Microsoft.VisualBasic.VBCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
    <providerOption name="CompilerVersion" value="v3.5"/>
    <providerOption name="OptionInfer" value="true"/>
    <providerOption name="WarnAsError" value="false"/>
    </compiler>
    </compilers>
    </system.codedom>
    <!--
    La sezione system.webServer è richiesta per eseguire ASP.NET AJAX in Internet
    Information Services 7.0. Non è necessaria per la versione precedente di IIS.
    -->
    <system.webServer>
    <validation validateIntegratedModeConfiguration="false"/>
    <modules>
    <remove name="ScriptModule"/>
    <add name="ScriptModule" preCondition="managedHandler" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
    </modules>
    <handlers>
    <remove name="WebServiceHandlerFactory-Integrated"/>
    <remove name="ScriptHandlerFactory"/>
    <remove name="ScriptHandlerFactoryAppServices"/>
    <remove name="ScriptResource"/>
    <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFact ory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
    <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFact ory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
    <add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
    </handlers>
    </system.webServer>
    <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
    <dependentAssembly>
    <assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35"/>
    <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/>
    </dependentAssembly>
    <dependentAssembly>
    <assemblyIdentity name="System.Web.Extensions.Design" publicKeyToken="31bf3856ad364e35"/>
    <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/>
    </dependentAssembly>
    </assemblyBinding>
    </runtime>
    </configuration>

  7. #7
    L'avatar di SignIn
    SignIn non è in linea Scribacchino
    Luogo
    Milano
    Post
    1,026
    ...quello che ti ho chiesto non è certo la versione di IIS, leggi attentamente quello che c'è scritto nel mio post.
    Puoi provare (per capire meglio l'errore) a sostituire la sezione customErrors (ovviamente non si deve trovare in una sezione di commento come è attualmente) con la seguente:
    codice:
    <customErrors mode="Off"/>
    Inoltre visto che la versione di IIS è la 6 non è necessaria la sezione system.webServer. Sostituirla con:
    codice:
    </system.webServer>
    Esegui l'upload del file web.config sul server e verifica nuovamente
    Ultima modifica di SignIn; 20-04-2009 22:58 

  8. #8
    massimoflorian non è in linea Scolaretto
    Post
    267
    Configuration Error body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;} p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px} b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px} H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red } H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon } pre {font-family:"Lucida Console";font-size: .9em} .marker {font-weight: bold; color: black;text-decoration: none;} .version {color: gray;} .error {margin-bottom: 10px;} .expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; } Ho effettuato la modifica ma mi da questi errori.

    E' una questione di compatibilità?

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Could not load file or assembly 'Microsoft.ReportViewer.WebForms, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

    Source Error:

    Line 46: <add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" /> Line 47: <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" /> Line 48: <add assembly="Microsoft.ReportViewer.WebForms, Version=9.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" /> Line 49: <add assembly="Microsoft.ReportViewer.Common, Version=9.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" /> Line 50: </assemblies>
    Source File: D:\Inetpub\webs\brunoiparruccheriit\web.config Line: 48

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Microsoft.ReportViewer.WebForms, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' could not be loaded.

    WRN: Assembly binding logging is turned OFF. To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1. Note: There is some performance penalty associated with assembly bind failure logging. To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
    Version Information: Microsoft .NET Framework Version:2.0.50727.3082; ASP.NET Version:2.0.50727.3082

  9. #9
    L'avatar di SignIn
    SignIn non è in linea Scribacchino
    Luogo
    Milano
    Post
    1,026
    Vedo che fai uso di ReportViewer....hai verificato se è possibile usarli su Aruba?
    Inoltre presumo (perchè non ho mai eseguito prove in merito) che l'assembly in questione dovrebbe girare in FullTrust...ma su Aruba penso che te lo puoi scordare

  10. #10
    massimoflorian non è in linea Scolaretto
    Post
    267
    dovrei chiedere ad aruba.
    Francamente no.
    non ho chiesto ad aruba.
    domani mi informo ma per quanto riguarda l'assembly di cui parlavi è indispensabile per fare girare tutto il resto?
    Anche le webform collegate con i database?
    Se fosse così puoi consigliarmi un provider che supporta per certo tutte le caratteristiche per potere provare un pò tutto?

+ Rispondi al Thread
Pagina 1 di 2 12 ultimoultimo

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi