Salve amici ho un banalissimo problema di cui non trovo soluzione, ho una webform1.aspx con questo codice a cui vado ad applicare un CSS e funziona bene:

codice:
<%@ Page Language="vb" AutoEventWireup="false" CodeBehind="WebForm1.aspx.vb" Inherits="PROVA.WebForm1" %>

<!DOCTYPE html>

<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
     <link rel="stylesheet" href="Button/css/style.css"/>     
</head>
<body>
    <form id="form1" runat="server">
    <div>
    </div>
        <table class="auto-style1">
       
                    <asp:CheckBox ID="toggle" runat="server" AutoPostBack="True" />
                                            
        </table>
    </form>
</body>
</html>
Se applico lo stesso CSS a una pagina dipendente da una Master Page non funziona:

codice:
'Master'

<%@ Master Language="VB" AutoEventWireup="false" CodeBehind="Site1.master.vb" Inherits="GDC_2016_2017.Site1" %>

<!DOCTYPE html>

<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
         <link rel="stylesheet" href="~/Button/css/style.css"/>

    <title></title>
  PROVA
</head>
<body>
    <form id="form1" runat="server">
    <div>
        <asp:ContentPlaceHolder ID="ContentPlaceHolder1" runat="server">
        
        </asp:ContentPlaceHolder>
    </div>
    </form>
</body>
</html>

'Pagina dipendente da Master Page'

<%@ Page Title="" Language="vb" AutoEventWireup="false" MasterPageFile="~/Site1.Master" CodeBehind="WebForm2.aspx.vb" Inherits="XXXXX.WebForm2" %>
<asp:Content ID="Content2" ContentPlaceHolderID="ContentPlaceHolder1" runat="server">
    <div>
                            <asp:CheckBox ID="toggle" runat="server" AutoPostBack="True" />

    </div>
</asp:Content>
Dove sbaglio?
Grazie a tutti.
Un saluto.