+ Rispondi al Thread
Visualizzazione dei risultati da 1 a 8 su 8

Discussione: [ASP.Net]web config

  1. #1
    perla0279 non è in linea Scolaretto
    Post
    230

    [ASP.Net]web config

    Ciao

    finalmente sono a buon punto con il mio progetto.....quindi ho deciso di caricarlo sul server e provare a vedere se funziona.


    ora ho grossi problemi con il web config.....che sembra non essere configurato correttamente.

    mi dà questo messaggio di errore quando lancio la pagina:
    codice:
     Runtime Error 
    
                                 Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine. 
    
                 Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".
    
                                                                           <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="Off"/>
        </system.web>
    </configuration>                                                               
                 Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.
    
                                                                           <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>
    elena

  2. #2
    L'avatar di SignIn
    SignIn non è in linea Scribacchino
    Luogo
    Milano
    Post
    1,026
    ...in genere ci può essere o un errore nel web.config(caratteri non validi ecc) oppure nel tuo la cosa più probabile è che devisettare ad On la modalità di errore personalizzato:
    codice:
    <customErrors mode="On" DefaultRedirect="mycustompage.htm"/>

  3. #3
    perla0279 non è in linea Scolaretto
    Post
    230
    ho provato sia cosi:
    codice:
     <customErrors mode="Off" DefaultRedirect="mycustompage.htm"/>
    che così:
    codice:
     <customErrors mode="On" DefaultRedirect="mycustompage.htm"/>
    ma mi dà sempre errore..........
    non so proprio cosa fare

  4. #4
    L'avatar di SignIn
    SignIn non è in linea Scribacchino
    Luogo
    Milano
    Post
    1,026
    ....nel primo caso devi scrivere:
    codice:
    <customErrors mode="Off"/>
    ...si può avere l'url del sito che hai uploadato?...ed inoltre su quale hosting si trova?

  5. #5
    perla0279 non è in linea Scolaretto
    Post
    230
    Documento senza titolo
    è il sito web che sto cercando di fare funzionare


    la pagina che non funziona è www.artistic.it/galleria.aspx


    per l'hosting è un pò più complessa....
    ho acquistato un server vituale su Aruba, quindi l'hosting è aruba....però se c'è bisogno di configurare qualcosa sul server ho accesso anche a quello.

  6. #6
    L'avatar di SignIn
    SignIn non è in linea Scribacchino
    Luogo
    Milano
    Post
    1,026
    ...due cose:
    1)hai provato a mettere ad Off come ti ho mostrato? se si allora mi sa che devi postare il web.config per vedere se non ci sono errori di sintassi
    2)aruba ha configurato il tutto?...cioè era già stata creata la web folder ecc
    Ultima modifica di SignIn; 02-03-2008 18:28 

  7. #7
    perla0279 non è in linea Scolaretto
    Post
    230
    Ho creato io il dominio tramite il pannello di controllo..............

    aruba ha messo gli stumenti, nel senso che il server era già configurato da loro io non ci ho messo mano.......

    scusami ma non so dove guardare se il web folder è configurato....


    questo è il web config come è adesso:
    codice:
    <?xml version="1.0"?>
    <configuration>
      <connectionStrings>
      
        <!--<add name="ArtisticConnectionString" connectionString="Data Source=WIN3854\SQLEXPRESS;Initial Catalog=xxxxxx;User Id=xxxx;password=axxxx"
             
          providerName="System.Data.SqlClient" />
     <add name="ArtisticConnectionString" connectionString="Data Source=02PERLA-CASA\SQLEXPRESS;Initial Catalog=SitoIDSistemi;Integrated Security=True"
             
          providerName="System.Data.SqlClient" />
     -->
             </connectionStrings>
      <customErrors mode="Off" DefaultRedirect="mycustompage.htm"/>
    
      <system.web>
        <!-- 
                Set compilation debug="true" to insert debugging 
                symbols into the compiled page. Because this 
                affects performance, set this value to true only 
                during development.
    
                Visual Basic options:
                Set strict="true" to disallow all data type conversions 
                where data loss can occur. 
                Set explicit="true" to force declaration of all variables.
            -->
        <compilation debug="true" strict="false" explicit="true" />
        <pages>
          <namespaces>
            <clear />
            <add namespace="System" />
            <add namespace="System.Collections" />
            <add namespace="System.Collections.Specialized" />
            <add namespace="System.Configuration" />
            <add namespace="System.Text" />
            <add namespace="System.Text.RegularExpressions" />
            <add namespace="System.Web" />
            <add namespace="System.Web.Caching" />
            <add namespace="System.Web.SessionState" />
            <add namespace="System.Web.Security" />
            <add namespace="System.Web.Profile" />
            <add namespace="System.Web.UI" />
            <add namespace="System.Web.UI.WebControls" />
            <add namespace="System.Web.UI.WebControls.WebParts" />
            <add namespace="System.Web.UI.HtmlControls" />
          </namespaces>
        </pages>
        <!--
                The <authentication> section enables configuration 
                of the security authentication mode used by 
                ASP.NET to identify an incoming user. 
            -->
        <authentication mode="Windows" />
        <!--
                The <customErrors> section enables configuration 
                of what to do if/when an unhandled error occurs 
                during the execution of a request. Specifically, 
                it enables developers to configure html error pages 
                to be displayed in place of a error stack trace.
    
            <customErrors mode="RemoteOnly" defaultRedirect="GenericErrorPage.htm">
                <error statusCode="403" redirect="NoAccess.htm" />
                <error statusCode="404" redirect="FileNotFound.htm" />
            </customErrors>
            -->
      </system.web>
    
      <appSettings>
        <!--   User application and configured property settings go here.-->
        <!--   Example: <add key="settingName" value="settingValue"/> -->
        <add key="CacheViewState" value="true" />
        <add key="SetDbLanguage" value="false" />
        <add key="TimeoutValue" value="120" />
        <add key="TimeoutExport" value="680" />
      </appSettings>
      
     
    </configuration>

  8. #8
    L'avatar di SignIn
    SignIn non è in linea Scribacchino
    Luogo
    Milano
    Post
    1,026
    ,,,bhè si sembra abbastanza evidente che il web.config contiene degli errori. La sezione customErrors è ripetuta due volte, che tra l'altro una si trova in una sezione del web.config non consentita(configuration).
    La sezione customErrors si deve trovare nella sezione system.web, inoltre se imposti a Off non ci deve essere nessuna pagina di customizzazione degli errori(come ti avevo già indicato in un post precedente):
    codice:
    <customErrors mode="Off"/>
    ...poi una cosa che non c'entra nulla: la stringa di connessione è giusto che sia commentata
    ...infine bisogna vedere dove hai copiato i tuoi file, come è strutturato il tutto ecc(ma su questo non posso darti una mano dato che bisognerebbe accedere al web server)
    Ultima modifica di SignIn; 02-03-2008 19:50 

+ Rispondi al Thread

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi