+ Rispondi al Thread
Pagina 1 di 2 12 ultimoultimo
Visualizzazione dei risultati da 1 a 10 su 14

Discussione: [ASP.Net]pubblicazione sito e errori

  1. #1
    comm64 non è in linea Scolaretto
    Post
    50

    [ASP.Net]pubblicazione sito e errori

    Salve a tutti, ho un problemuccio
    ho finito la mia applicazione e sono andato alla ricerca di qualche hosting gratuito per testarla
    ho trovato questo Web Hosting, Free Web Site Builder & Domain Name, Web Hosting Made Easy By Brinkster che offre un pò di spazio per gli sviluppatori al fine di fare dei test...

    però mi sono imbattuto in un errore strano che nel server di visual studio e nel mio IIS su windows xp non avveniva
    codice:
    
    Compiler Error Message: CS0246: The type or namespace name  'DbManager' could not be found (are you missing a using directive or an assembly  reference?)
    
    Source Error:
    
       
     Line 34:                 
    Line 35:             }
    Line 36:             DbManager dbm = new DbManager();
    Line 37:             DataSet ds = dbm.ControllaUsername(TxtScegliUsername.Text);
    Line 38:             //controllo se esiste già un username per la registrazione
    qualcuno sa di cosa si tratta?

  2. #2
    L'avatar di SignIn
    SignIn non è in linea Scribacchino
    Luogo
    Milano
    Post
    1,026
    ...verifica di aver caricato tutte le dll

  3. #3
    comm64 non è in linea Scolaretto
    Post
    50
    Quote Originariamente inviato da SignIn Visualizza il messaggio
    ...verifica di aver caricato tutte le dll
    infatti sign.. non avevo usato dal menu genera: pubblica sito web e non avevo creato le dll

    adesso ci riprovo


    Sei sempre un mito!

    Grazie

  4. #4
    comm64 non è in linea Scolaretto
    Post
    50
    Hai mai visto quest'altro errore?

    codice:
     Server Error in '/' Application.  
    
     Configuration Error 
    
    Description:  An error occurred during the processing of a configuration file required to  service this request. Please review the specific error details below and modify  your configuration file appropriately. 
    
    Parser Error Message: It  is an error to use a section registered as  allowDefinition='MachineToApplication' beyond application level.  This error can  be caused by a virtual directory not being configured as an application in  IIS.
    
    Source Error: 
    
       Line 7:  
    Line 8:  	<system.web>
    Line 9:  		<authentication mode="Forms">
    Line 10: 			<forms name=".MYSITEAUTH" loginUrl="Admin/Login.aspx" protection="All" path="/">
    Line 11: 				<credentials passwordFormat="Clear">

  5. #5
    L'avatar di SignIn
    SignIn non è in linea Scribacchino
    Luogo
    Milano
    Post
    1,026
    ...ad occhio mi sembra quasi che non sia stata creata la web folder

  6. #6
    comm64 non è in linea Scolaretto
    Post
    50
    ciao ho trovato questo articolo in inglese: ma non ci ho capito molto potrebbe essere questa la soluzione?

    You may get this error when trying to browse an asp.net application.

    The debug information shows that "This error can be caused by a virtual directory not being configured as an application in IIS."

    However, this error occurs primarily out of 2 scenarios.

    1. When you create an new web application using visual studio.net, it automatically creates the virtual directory and configures it as an application.
    However, if you manually create the virtual directory and it is not configured as an application, then you will not be able to browse the application and
    may get the above error. The debug information you get as mentioned above, is applicable to this scenario.

    To resolve it, Right Click on the virtual directory - select properties and then click on "Create" next to the "Application" Label and the textbox. It will
    automatically create the "application" using the virtual directory's name. Now the application can be accessed.


    2. When you have sub-directories in your application, you can have web.config file for the sub-directory. However, there are certain properties which cannot
    be set in the web.config of the sub-directory such as authentication, session state (you may see that the error message shows the line number where the
    authentication or sessionstate is declared in the web.config of the sub-directory). The reason is, these settings cannot be overridden at the sub-directory level
    unless the sub-directory is also configured as an application (as mentioned in the above point).

    Mostly we have the practice of adding web.config in the sub-directory if we want to protect access to the sub-directory files (say, the directory is admin and we
    wish to protect the admin pages from unathorized users).

    But actually, this can be achieved in the web.config at the application's root level itself, by specifing the location path tags and authorization, as follows:-

    <location path="Admin">
    <system.web>
    <authorization>
    <allow roles="administrators" />
    <deny users="*" />
    </authorization>
    </system.web>
    </location>

    However, if you wish to have a web.config at the sub-directory level and protect the sub-directory, you can just specify the Authorization mode as follows:-

    <configuration>
    <system.web>
    <authorization>
    <allow roles="administrators" />
    <deny users="*" />
    </authorization>
    </system.web>
    </configuration>

    Thus you can protect the sub-directory from unauthorized access.

    Cheers.
    Questo invece è il mio web.config
    codice:
    <?xml version="1.0"?>
    <configuration>
        <!-- Altre eventuali impostazioni -->
        <system.web>
            <authentication mode="Forms">
                <forms name=".MYSITEAUTH" loginUrl="Admin/Login.aspx" protection="All" path="/">
                    <credentials passwordFormat="Clear">
                        <user name="Admin" password="Admin"/>
                        <user name="paperon" password="depaperoni"/>
                    </credentials>
                </forms>
            </authentication>
            <authorization>
                <allow users="*"/>
            </authorization>
            <compilation debug="true"/></system.web>
        <location path="Admin">
            <system.web>
                <authorization>
                    <deny users="?"/>
                </authorization>
            </system.web>
        </location>
    </configuration>

    nel mio progetto ho una cartella chiamata "Admin" dove ho messo le pagine riservate per l'amministratore

  7. #7
    L'avatar di SignIn
    SignIn non è in linea Scribacchino
    Luogo
    Milano
    Post
    1,026
    ...la stessa cosa che ti ho già detto io...una web folder sull'hosting è stata creata(su IIS)?

  8. #8
    comm64 non è in linea Scolaretto
    Post
    50
    Quote Originariamente inviato da SignIn Visualizza il messaggio
    ...la stessa cosa che ti ho già detto io...una web folder sull'hosting è stata creata(su IIS)?

    ciao penso di si..

    mi sono creato una cartella Admin direttamente dove faccio l'upload dei file sul sito che penso sia quella la webfolder

    ecco la situazione(ho pensato... potrebbe essere una limitazione dell'hosting?)
    ImageShack - Hosting :: immaginezv3.jpg

  9. #9
    L'avatar di SignIn
    SignIn non è in linea Scribacchino
    Luogo
    Milano
    Post
    1,026
    ...bhè non posso dire nulla dallo screen...potrei azzardare nel dirti che secondo me la cartella del sito(web folder) è comm64(admin è una semplice cartella creata da te), ma in caso di dubbi puoi sempre chiedere(aprendo un ticket ecc) direttamente alla società che gestisce l'hosting

  10. #10
    comm64 non è in linea Scolaretto
    Post
    50
    Quote Originariamente inviato da SignIn Visualizza il messaggio
    ...bhè non posso dire nulla dallo screen...potrei azzardare nel dirti che secondo me la cartella del sito(web folder) è comm64(admin è una semplice cartella creata da te), ma in caso di dubbi puoi sempre chiedere(aprendo un ticket ecc) direttamente alla società che gestisce l'hosting

    ciao Comm64 me l'hanno creata loro... infatti questo è il path completo che mi hanno dato

    c:\sites\content\c\o\m\comm64


    adesso vedo se ci sta qualcuno dell'assistenza

+ Rispondi al Thread
Pagina 1 di 2 12 ultimoultimo

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi