+ Rispondi al Thread
Visualizzazione dei risultati da 1 a 4 su 4

Discussione: [ASP,IIS 5.0]Problemi

  1. #1
    Revan1985 non è in linea Novello
    Post
    28

    [ASP,IIS 5.0]Problemi

    Allora, ho un fastidioso problema con IIS e ASP
    dopo che son riuscito a far funzionare IIS con le pagine asp e con mozzilla, ho un problema coi driver di IIS...
    allora, ho creato una pagina ASP da cui devo prelevare dai dati.
    La pagina è questa :

    codice:
    <% LANGUAGE = "VBScript" %>
    <%
        Dim logout
        Dim conn, result
        logout = Request.QueryString( "action" )
        
        ' Se la sessione login è diversa da uno allora esegue la verifica.
        if session( "login" ) <> 1 then
            ' Richiama i valori inseriti nel form di index.html
            username = request.Form( "user" )
            password = request.Form( "password" )
            
            Strsql = "SELECT * WHERE Login = '" & user & "' AND Password = '" & password & "'"
            Set conn = Server.CreateObject( "ADODB.Connection" )
            Set result = Server.CreateObject( "ADODB.Recordset" )
            conn.Open "Driver = ,Microsoft Access Driver (*.mdb);DBQ=" & Server.MapPath( "Database1.mdb" )
            rs.Open Strsql, conn
            
            ' Se i valori della tabella esistono, allora session( "login" ) = 1 altimenti
            ' reindirizza alla pagina Index.asp
            if not result.eof then
                session("login") = 1
            else
                Response.Redirect( "index.asp" )
            end if
            set result = nothing
            set conn = nothing
        end if
    %>

    il problema è che quando la faccio andare, esce questo messaggio nel server :
    codice:
    Tipo di errore:
    Microsoft OLE DB Provider for ODBC Drivers (0x80004005)
    [Microsoft][Driver Manager ODBC] Nome origine dati non trovato e driver predefinito non specificato.
    /Notturna/cms/login.asp, line 16
      
    Tipo di browser:
    Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5  
    da quanto ho letto per internet può essere :
    il server che non trova il database [ che esiste e il percorso è esatto, è sia in lettura che scrittura ]
    il driver che non è specificato [ pecccato sia questo conn.Open "Driver = ,Microsoft Access Driver (*.mdb);DBQ=" & Server.MapPath( "Database1.mdb" ) ]

    non capisco cosa non vada...
    se devo aggiornare qualcosa di iis, potete dirmi cosa?
    grazie

  2. #2
    Revan1985 non è in linea Novello
    Post
    28
    risolto il problema della connessione...
    solo una cosa...
    riesco a fare la query e tutto, ma sulla query esce questo

    codice:
     ADODB.Recordset (0x800A0BB9)
    Gli argomenti non sono di tipo valido, non sono compresi nell'intervallo consentito o sono in conflitto.
    /Notturna/cms/login.asp, line 17
    


    la query
    codice:
    Strsql = "SELECT FROM Utente * WHERE Login = '" & username & "' AND Password = '" & password & "'"
    non mi sembra sbagliata...
    Ultima modifica di Revan1985; 31-07-2007 23:47 

  3. #3
    L'avatar di SignIn
    SignIn non è in linea Scribacchino
    Luogo
    Milano
    Post
    1,026
    ...si che è sbagliata
    select * from tabella

  4. #4
    Revan1985 non è in linea Novello
    Post
    28
    oooppssss....
    l'avevo scritta giusta, ma diomenticando qui FROM Utente, l'ho piazzata nella parte sbagliata

+ Rispondi al Thread

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi