+ Rispondi al Thread
Visualizzazione dei risultati da 1 a 3 su 3

Discussione: Non riconosce piu la funzione NZ

  1. #1
    L'avatar di kmsta
    kmsta non è in linea Scolaretto
    Post
    64

    Non riconosce piu la funzione NZ

    Salve, ho installato un Db access sviluppato con 2007 su una macchina con Windows 10.
    Il Db funziona correttamente tranne le sottomaschere che hanno come origine una query contenente la funzione NZ.
    Ho provato ad andare all'origine della query ma dove è presente la funzione NZ mi da errore ( Access nn riconosce NZ)
    Cosa dovrei fare?
    Questi sono i riferimenti esistenti nel db
    • Visual Basic for application
    • Microsoft Access 12.0 Objet library
    • Ole Automatition
    • Microsoft ActiveX Data Objet 2.1 Library
    • Microsoft Dao 3.6 Objet Library

  2. #2
    OsvaldoLaviosa non è in linea Topo di biblioteca
    Luogo
    Conversano
    Post
    2,808
    Puoi mostrare il codice SQL o VBA dove nasce l'errore?
    Ditemi i campi di tutte le vostre tabelle.

  3. #3
    L'avatar di @Alex
    @Alex non è in linea Very Important Person
    Post
    15,660
    Ciao Alessandro Daniel... ho già letto questa domanda... mi pare ICAA...? Sbaglio...?
    99% la soluzione è i riferimenti oppure errori di scrittura del codice... ad esempio errate dichiarazioni o doppie...
    Se ad esempio non usi OPTION EXPLICIT difficilmente troverai il problema eseguendo il COMPILE.
    Ultima modifica di @Alex; 12-11-2018 08:56 
    @Alex
    Il CROSSPOST è VIETATO
    Mirror al vecchio sito WEB(salvare i Demo riassegnando l'estensione (.Zip/.Rar/.Exe in base all'icona...):
    http://mirror.masterdrive.it/alessandrobaraldi/
    Leggi il
    Regolamento del Forum e nel comprenderne la filosofia rispettalo.

+ Rispondi al Thread

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire repliche
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi